Columbus Navigation Download

Audio, Navigation, Electronic Faults and Fixes
Post Reply
Bairektar01
Posts: 1
Joined: Wed Feb 05, 2020 4:41 am

Columbus Navigation Download

Post by Bairektar01 » Wed Feb 05, 2020 5:11 am

I have had problems downloading the latest version. 1 They say a 32GB SD is required but when I tried I got the message that the capacity was too small. Put in a 64GB C10 and it worked. Internet speeds and reliability not good where I am so many aborted attempts to download the file. Ended up being 25GB so no idea why the 32GB did not work. Has there been any discussion about having country specific downloads? I am in Australia and don't need the rest of the world?
I have not tried uploading the file to the system. Any tips or tricks I need to know? AliB

old man
Posts: 474
Joined: Sun Aug 19, 2018 7:23 am
Location: Somerset

Re: Columbus Navigation Download

Post by old man » Wed Feb 05, 2020 10:26 am

I have done this twice now, both times onto the same 32gb memory stick. The first time everything went smoothly, but the second time I had a similar experience to you when downloading from the portal to the memory stick i.e. I had to do it 3 times before it worked properly. My internet speed is fine by the way. Do remember that many memory devices already have some of their memory in use before you get them, so the full stated 32gb might not be available.

On both occasions though, downloading from memory stick to car has gone faultlessly. Just plug in your card and follow the instructions on your Columbus. Each time, I've started the download to the car just before going out somewhere e.g supermarket and left it to do its own thing. It even continues to download when ignition is switched off whilst in the supermarket. Don't be tempted to do the download to your car when its parked on your drive with the engine not running. It does tend to run your battery down quickly and there'll be warnings flashing up on your screen to tell you that and to start your engine. From memory, this part took a little over an hour.

I've only used the sat nav in anger once since the latest download and it led me a merry dance getting me to my destination. This might be due to a corruption in the download, but in fairness it could also have been my fault in programming it wrongly, because normally my wing man (wife) does it when we're off to pastures new.
Next time out will tell me who's fault it was ;)

Post Reply